Wednesday, October 1, 2008

Best varible name ever.

So today I was looking at a coworker’s code. I am doing CURD processes for the system I am working on this isn’t creative code or even variable code beyond you change the names of what you are keeping in the database. But while grabbing his code to use as a template for the new function I ran across this little pearl of code. My work went from boring to enjoyable in second all because of one line of code that made me laugh. Her it is.

  716 object of_my_affection = command.ExecuteScalar();

Sometimes having a bit of fun in your code makes it better than all the naming conventions you could ever use.

No comments: